System requirements for Mediathread

The Mediathread team supports the latest versions of Firefox, Chrome and Safari. Many other browsers can use much of the functionality of Mediathread but it is not guaranteed.  A high speed Internet connection is required. Video requires different plugins based on the source. Flash video requires Flash 8 or higher. Some video requires the Quicktime plugin or the RealPlayer plugin.

Feedback and Knowledge Base